Installing VIM in R on Mint 17

For data imputation, for simplicity I like to use single imputation instead of multiple imputation. This can easily be done with the VIM package using the irmi command. So, I tried to install VIM in R on Mint 17. However:

* installing *source* package ‘robustbase’ …
** package ‘robustbase’ successfully unpacked and MD5 sums checked
** libs
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG      -fpic  -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -g  -c R-rng4ftn.c -o R-rng4ftn.o
gfortran   -fpic  -g -O2 -fstack-protector-strong  -c eigen.f -o eigen.o
/bin/bash: gfortran: command not found
make: *** [eigen.o] Error 127
ERROR: compilation failed for package ‘robustbase’
* removing ‘/home/lenovo/R/x86_64-pc-linux-gnu-library/3.1/robustbase’
Warning in install.packages :
installation of package ‘robustbase’ had non-zero exit status
* installing *source* package ‘vcd’ …
** package ‘vcd’ successfully unpacked and MD5 sums checked
** R
** data
*** moving datasets to lazyload DB
** demo
** inst
** preparing package for lazy loading
** help
*** installing help indices
** building package indices
** installing vignettes
** testing if installed package can be loaded
* DONE (vcd)
ERROR: dependency ‘robustbase’ is not available for package ‘VIM’
* removing ‘/home/lenovo/R/x86_64-pc-linux-gnu-library/3.1/VIM’
Warning in install.packages :
installation of package ‘VIM’ had non-zero exit status

Now, for many packages, one has to use Synaptic Package Manager or equivalent (Software Manager, apt-get etc.) outside R to install R packages. I installed robustbase thru Synaptic and then tried to install in R again. However:

* installing *source* package ‘robustbase’ …
** package ‘robustbase’ successfully unpacked and MD5 sums checked
** libs
gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG      -fpic  -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -g  -c R-rng4ftn.c -o R-rng4ftn.o
gfortran   -fpic  -g -O2 -fstack-protector-strong  -c eigen.f -o eigen.o
/bin/bash: gfortran: command not found
make: *** [eigen.o] Error 127
ERROR: compilation failed for package ‘robustbase’
* removing ‘/home/lenovo/R/x86_64-pc-linux-gnu-library/3.1/robustbase’
Warning in install.packages :
installation of package ‘robustbase’ had non-zero exit status

There is a gforstran package in Synaptic, so I installed that. Then back to R and try to install robustbase again. But then:

/usr/bin/ld: cannot find -llapack
/usr/bin/ld: cannot find -lblas
collect2: error: ld returned 1 exit status
make: *** [robustbase.so] Error 1
ERROR: compilation failed for package ‘robustbase’
* removing ‘/home/lenovo/R/x86_64-pc-linux-gnu-library/3.1/robustbase’

Anyway, sometimes packages in R work despite some missing sub-sub dependencies, and it did in this case. For me. At this time. Using Linux is a new experience every time…

Views All Time
Views All Time
606
Views Today
Views Today
1